Categories
Uncategorized

Fixing “You have already activated rake 10.1.0, but your Gemfile requires rake 10.0.0″

How to fix the “Gem::LoadError: You have already activated rake 10.1.0, but your Gemfile requires rake 10.0.0. Using bundle exec may solve this.” error by updating the gem.

Just a quick note for searchers.
Maybe you got this error:

Gem::LoadError: You have already activated rake 10.1.0, but your Gemfile requires rake 10.0.0. Using bundle exec may solve this.
~/.rvm/gems/ruby-2.0.0-p0@global/gems/bundler-1.3.4/lib/bundler/runtime.rb:33:in `block in setup’
~/.rvm/gems/ruby-2.0.0-p0@global/gems/bundler-1.3.4/lib/bundler/runtime.rb:19:in `setup’
~/.rvm/gems/ruby-2.0.0-p0@global/gems/bundler-1.3.4/lib/bundler.rb:120:in `setup’
~/.rvm/gems/ruby-2.0.0-p0@global/gems/bundler-1.3.4/lib/bundler/setup.rb:17:in `
~/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:110:in `require’
It’s easy to fix. Just run:

$ bundle update rake # or whatever your gem is called
If this does not work, you can use bundle exec as the error says.